大虾们看看ACM题目

来源:百度知道 编辑:UC知道 时间:2024/06/28 13:10:02
There is a hill with n holes around. The holes are signed from 0 to n-1.A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES
我的代码是:
#include <iostream>
using namespace std;

int main()
{
int m,n,l,tem,j

你这种写法时间复杂度比较高。比如n 非常大,m非常小时时间就用很多了
楼主好好思考下,其实这题考的是最大公约数,如果最大公约数不等于1,狼进入的洞就肯定会循环,也就存在安全的洞了,楼主试试我的C代码,有问题的话再讨论下
#include<stdio.h>
int F(int m,int n)
{
int t;
while(n%=m,n)
t=m,m=n,n=t;
return m;
}
int main()
{
int m,n,k,t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&m,&n);
k=F(m,n);
if(k==1)
printf("NO\n");
else
printf("%YES\n");
}
return 0;
}